Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6627840

Deployment Toolkit updates for new Java Plug-In, add isPlugin2()

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b12
    • CPU:
      generic
    • OS:
      generic
    • Verification:
      Verified

      Backports

        Description

        The DT needs to be updated to add support for the new Java Plug-In. Known issues at this time:

        1. Support for per-applet JVM command-line arguments via "java_arguments" parameter.
        2. May need updates for JRE version selection for individual applets. Don't know exactly how this is handled, or whether the backward compatibility mechanisms in 6606284 combined with whatever DT currently does will suffice. Direct support for the "java_version" parameter would be preferable.
        3. The detection mechanism should be augmented if possible to indicate that the new Java Plug-In is available.
        4. In the context of the new Java Plug-In the concept of the "browser Java version" is obsolete and needs to be reconsidered.

        There may be other issues.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                herrick Andy Herrick
                Reporter:
                kbr Kenneth Russell (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: