Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6635826

New plug-in does not run on top of JDK 1.4.2 because of System.getenv() use and other reasons

    Details

    • Subcomponent:
    • Introduced In Build:
      b08
    • Introduced In Version:
    • Resolved In Build:
      b09
    • CPU:
      generic
    • OS:
      generic
    • Verification:
      Verified

      Description

      The new plug-in does not launch on top of JDK 1.4.2 because it calls System.getenv() to fetch debugging-related environment variables and getenv() was only "re-enabled" in JDK 1.5. There may be other reasons it doesn't work on top of JDK 1.4.2 such as 6609139 but this is the first and most obvious failure that needs to be fixed. It isn't essential that these environment variables actually be fetched correctly but it is essential that fetching them not break the plug-in.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kbr Kenneth Russell (Inactive)
                Reporter:
                kbr Kenneth Russell (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: