Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6642046

Main not found then installation of component get started

    Details

    • Subcomponent:
    • Resolved In Build:
      b23
    • CPU:
      x86
    • OS:
      windows_xp
    • Verification:
      Verified

      Description

      I have just tried to run 2-3 games from sun site, its all jnlp application. So, before running the installation its giving error" main not found " then it starts installing component. This error message is very wired.
      I am able to reproduce this in my machine (129.158.229.123 Vnc Password :vnc)

      These are the steps to reproduce the issue

      1.clear cache & Install 1.5.0 ( tried with 1.5.0_08 and 1.5.0_14)
      2.Install kernel JRE (I used promoted build 6u10b11)
      3.launch a JNLP application (
      javaws http://ebugster.sfbay.sun.com/dev/ebugster.jnlp or
      javaws http://java.sun.com/products/javawebstart/apps/notepad.jnlp )

      4. "Main Class Not Found .Program Will Exit " dialog will be displayed.
      5. Clicking Ok disposes the dialog and the application launches successfully.

      This error dialog is displayed only once after an installation.Second time the error dialog is not displayed.

      This doesn't happen if I repeat the steps using 1.4.2 in step 1.

      I am not able to reproduce the same bug in all XP Prof machines.
      Its not reproducible in jlab424.india.sun.com (VNC Pwd:vnc123),but reproducible in jdsn9.india.sun.com((VNC Pwd:vnc123))

      During webstart automation I am getting this same error dialog (Main Class Not Found.Program Will Exit) for only these three tests
      suite_javaws_pickupJRE /from before_upgraded
      suite_javaws_pickupJRE /after_reinstalled
      suite_javaws_pickupJRE /from jaws150
      .If I click Ok for the dialog,the test will pass.otherwise other tests (total 7 tests) also will fail bcoz of timeout.This error is reproducible in all the machines.

      All the tests in this suite deals with picking up previous JREs(1.4.2 and 1.5.0 )But other tests in this suite are passing.

      I am getting this errror in console after running suite_javaws_pickupJRE/from jaws150
      TEST from_jaws150 from_jaws150 7/7 7/7 FAIL
      Got "java.io.IOException: Cannot run program "C:/Program Files/Java/jr
      a": CreateProcess error=2, The system cannot find the file specified"
      cution of "${TEST_JRE_HOME}/bin/java -cp ${COMPONENT_WS}/share/lib/cl
      in.jar CloseNativeWindow Java(TM) "
      HARNESS ENDED: Mon Feb 04 22:41:29 GMT+05:30 2008

        Attachments

          Activity

            People

            • Assignee:
              enicholasunw Ethan Nicholas (Inactive)
              Reporter:
              vchoudhaorcl Vaibhav Choudhary (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: