Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6656520

Loading cacerts file from running JRE directory (JRE 1.4.2)

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 6u10
    • Fix Version/s: 6u7
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b01
    • CPU:
      x86
    • OS:
      windows_nt

      Backports

        Description

        Using JRE5 or JRE6 release, Java webstart application can force to use old JRE, such as JRE 1.4.2_15 in jnlp file, in current design, we are still loading cacerts file from JRE5 or JRE 6 directory, not JRE 1.4.2_15.

        With new certificate come from AOL has been added into cacerts file in JRE 5 and JRE 6, the JSSE api in JRE 1.4.2 can't parse this new certificate in cacerts file (lengthn > 4k), therefore the application will failed to load during loading cacerts file, the following exception will be thrown:

        java.secutrity.cert.CertificateParsingException in 5.0u15-b02

        java.security.cert.CertificateParsingException: java.io.IOException
        subject key, Unknown key spec, Invalid RSA modulus size.

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  dgu Dennis Gu (Inactive)
                  Reporter:
                  dgu Dennis Gu (Inactive)
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Imported:
                    Indexed: