Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6714370

Java applications failed with J2SDK 1.4.2_17 installed from packages on S10U5

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4
    • Resolution: Won't Fix
    • Affects Version/s: 1.4.2_17
    • Fix Version/s: 1.4-pool
    • Component/s: deploy
    • Labels:

      Description

      Customer installed J2SDK1.4.2_17 with the downloaded packages j2sdk-1_4_2_17-solaris-sparc.tar.Z and j2sdk-1_4_2_17-solaris-sparcv9.tar.Z on a v880 running S10U5. But it failed to run any Java applications.

      # /usr/jdk1.4/bin/java -jar /usr/java/demo/jfc/Font2DTest/Font2DTest.jar
      Exception in thread "main" java.lang.UnsupportedClassVersionError: org/GNOME/Accessibility/JavaBridge (Unsupported major.minor version 49.0)
              at java.lang.ClassLoader.defineClass0(Native Method)
              at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
              at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
              at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
              at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
              at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
              at java.security.AccessController.doPrivileged(Native Method)
              at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
              at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
              at java.lang.ClassLoader.loadClass(ClassLoader.java:282)
              at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
              at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
              at java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:684)
              at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:774)
              at java.awt.Window.getToolkit(Window.java:688)
              at java.awt.Window.init(Window.java:246)
              at java.awt.Window.<init>(Window.java:275)
              at java.awt.Frame.<init>(Frame.java:401)
              at javax.swing.JFrame.<init>(JFrame.java:198)
              at Font2DTest.main(Font2DTest.java:888)

      But if installed JDK with the self-extracted files j2sdk-1_4_2_17-solaris-sparc.sh and j2sdk-1_4_2_17-solaris-sparcv9.sh, it worked fine.

      The JAVA_HOME and CLASSPATH were set correctly. Apparently there is something wrong with the package version of the JDK.

      This seems only happened on S10U5.
      #uname -a
      SunOS sapsu1 5.10 Generic_127127-11 sun4u sparc SUNW,Sun-Fire-880

        Attachments

          Activity

            People

            • Assignee:
              robm Robert Mckenna
              Reporter:
              duke J. Duke (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: