Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6759617

Rename DEFAULT_LEASE_TIMEOUT to DEFAULT_REQUESTED_LEASE_TIMEOUT

    Details

      Description

      As of JDK 7 b37 the EventClient API makes use of a requestedlease, first as a parameter of one of the constructors, second by defining a method getRequestedLease().
      Considering the most common use case is perhaps not the constructor that takes a lease, I suggest to rename the parameter 'lease' and the method 'getLease()'.
      By the way the API defines the field DEFAULT_LEASE_TIMEOUT, not DEFAULT_REQUESTED_LEASE_TIMEOUT or the like.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                emcmanus Eamonn McManus
                Reporter:
                yjoan Yves Joan (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: