Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6772138

Can not change splash image if jnlp href is not set.

    XMLWordPrintable

    Details

    • Subcomponent:
    • Introduced In Version:
      6
    • Resolved In Build:
      b02
    • CPU:
      x86
    • OS:
      windows_xp
    • Verification:
      Verified

      Backports

        Description

        FULL PRODUCT VERSION :
        java version "1.6.0_10"
        Java(TM) SE Runtime Environment (build 1.6.0_10-b33)
        Java HotSpot(TM) Client VM (build 11.0-b15, mixed mode, sharing)

        ADDITIONAL OS VERSION INFORMATION :
        Microsoft Windows XP [Version 5.1.2600] SP3

        EXTRA RELEVANT SYSTEM CONFIGURATION :
        CPU: Core2 Duo 2.33Ghz
        Ram: 1.96G
        Display: ATI Radeon HD 2400XT


        A DESCRIPTION OF THE PROBLEM :
        Here is jnlp sample application(webpad) included in jdk6. I just copy and add one line. "<icon kind="splash" href="splash.jpg"/>"


        <?xml version="1.0" encoding="utf-8"?>
        <jnlp spec="1.0" codebase="$$codebase">
           <information>
              <title>WebPad 1.0</title>
              <vendor>Sun Microsystems, Inc.</vendor>
              <icon kind="splash" href="splash.jpg"/> ===> just modified
           </information>
           <resources>
              <property name="jnlp.publish-url" value="$$context/publish"/>
              <j2se version="1.3+" href="http://java.sun.com/products/autodl/j2se"/>
              <jar href="webpad.jar" version="1.0"/>
              <jar href="jlfgr.jar" version="1.0"/>
              <extension name="Help System"
                   href="javahelp.jnlp">
                 <ext-download ext-part="javahelp" download="lazy" part="help"/>
              </extension>
              <jar href="holidays.jar" version="1.0" download="lazy" part="help"/>
           </resources>
           <application-desc main-class="WebPad"/>
        </jnlp>

        When startup, always displaying java default splash image.
        This problem still reproduced in JDK6 update7.
        But JDK5 update16 works fine.

        I think that this is regression bug.

        Please help us.


        REPRODUCIBILITY :
        This bug can be reproduced always.

        Release Regression From : 5.0u16
        The above release value was the last known release where this
        bug was not reproducible. Since then there has been a regression.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                herrick Andy Herrick
                Reporter:
                ndcosta Nelson Dcosta (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: