Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6823915

java/awt/Toolkit/RealSync/Test.java test failed just against SLES11 on 6u14b03

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      linux_suse_sles_11, os_x

      Description

      6u14b03 was tested on new SLES11 x86 system for a baseline. The named test case from a relevant 6u14b03 (test_j2se) Workspace failed just on this system and passed on the others Linux version that used (SLES10, SLES9, RHEL5, RHEL4, Solaris10_x86, WindowsXP).

      The following issue messages appeared in execution.

      "..
      ----------System.err:(37/5681)*----------
      Test failed: testType
      Cause: Wrong text:
      Cause: - Focus owner: java.awt.TextField[textfield0,3,24,194x173,text=,editable,selection=0-0]
      Cause: - Focused window: java.awt.Frame[frame0,100,100,200x200,layout=java.awt.BorderLayout,title=testType,resizable,normal]
      Events:
      java.awt.event.ContainerEvent[COMPONENT_ADDED,child=textfield0] on frame0
      java.awt.event.ComponentEvent[COMPONENT_RESIZED (100,100 200x200)] on frame0
      java.awt.event.ComponentEvent[COMPONENT_MOVED (100,100 200x200)] on frame0
      java.awt.event.ComponentEvent[COMPONENT_RESIZED (3,24 194x173)] on sun.awt.X11.XTextFieldPeer$XAWTTextField[,3,24,194x173,invalid,hidden,layout=javax.swing.plaf.basic.BasicTextUI$UpdateHandler,alignmentX=0.0,alignmentY=0.0,border=javax.swing.plaf.BorderUIResource$CompoundBorderUIResource@19f3736,flags=297,maximumSize=,minimumSize=,preferredSize=,caretColor=java.awt.SystemColor[i=13],disabledTextColor=javax.swing.plaf.ColorUIResource[r=128,g=128,b=128],editable=true,margin=javax.swing.plaf.InsetsUIResource[top=0,left=0,bottom=0,right=0],selectedTextColor=java.awt.SystemColor[i=12],selectionColor=java.awt.SystemColor[i=13],columns=0,columnWidth=0,command=,horizontalAlignment=LEADING,echoChar=\u0000]
      .."

      The full log file is attached.

      Please look in this issue to sort out if it's a particularity of a new platform.
      See the Comments
      The CR 6438721 has been submitted about the same failure on Solaris 10. It's very unlikely that it's a new platform-specific issue. Is it always reproducible failure?
      The failure is always reproducible on SLES11 x86 and it's passing on the others linux System I've mentioned above. It passed yesterday for me on Solaris 10 x86 I've used in one of automatic reruns that is implemented just for the failed/unstable tests. We use this mode for some awt/swing related tests that may need a several attempts to rerun to get passed, that's why I've mentioned earlier that it passed for me on Solaris10 and WindowsXP as well. Seems it was just a lucky case. It was failing on Solaris 10 (x86, sparc) today all the time. I just can put more automatic reruns to get it passed on Solaris10 in some attempt to know what kind of randomness might be as a cause. In anyway it does not look stable on Solaris. The issue message looks quite similar to CR 6438721 on Solaris with a minor distinctions that appear in each rerun as below

       " 48 ----------System.err:(50/4911)----------
          49 Test failed: testFocus2
          50 Cause: B1 couldn't get focus
          51 Cause: - Focus owner: null
          52 Cause: - Focused window: null
          53 Events:

          48 ----------System.err:(31/2326)----------
          49 Test failed: testPress
          50 Cause: Not pressed
          51 Cause: - Focus owner: null
          52 Cause: - Focused window: null

          48 ----------System.err:(43/8778)----------
          49 Test failed: testPressSwing
          50 Cause: Not pressed
          51 Cause: - Focus owner: javax.swing.JButton[,73,5,41x26,alignmentX=0.0,alignmentY=0.5,border=javax.swing.plaf.BorderUIResource$CompoundBorderUIResource@cf710e,flags=296,maximumSize=,minimumSize=,preferredSize=,defaultIcon=,disabledIcon=,disabledSelectedIcon=,margin=javax.swing.plaf.InsetsUIResource[top=2,left=14,bottom=2,right=14],paintBorder=true,paintFocus=true,pressedIcon=,rolloverEnabled=true,rolloverIcon=,rolloverSelectedIcon=,selectedIcon=,text=b,defaultCapable=true]"

      Again the issue for SLES11 look a little different as well at this point, as it was mentioned earlier.
      Just let you know that the test passed for me on Solaris 10 x86 (I guess the same would be for Solaris sparc) with the expected message below after I put more automatic reruns in the configuration (but it a matter of luck it passed in the initial iteration).

      " 59 elapsed time (seconds): 114.232
          60 ----------System.out:(0/0)----------
          61 ----------System.err:(2/50)----------
          62 Total results: ALL TESTS PASSED!!!
          63 STATUS:Passed.
          64 result: Passed. Execution successful"

      I assume it's a timing issue in the test code and it might need more sleep before go for some next method invocation in the runtime especially if "gc() & robot.mouseMove(loc.x+30, loc.y+40)" are explicitly used in processing.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ant Anton Tarasov
                Reporter:
                vpotokov Valerii Potokov (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: