Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6833252

using 1.4.2_19 GA release in an applet calling family class ID keeps wanting to upgrade to _20 J4B

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Not an Issue
    • Affects Version/s: 1.4.2_19
    • Fix Version/s: 1.4-pool
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • CPU:
      x86
    • OS:
      windows_xp

      Description

      Customer has 1.4.2_19 GA installed then installs 1.5.0_18 GA and when they load their applets that uses

            classid="clsid:CAFEEFAC-0014-0002-FFFF-ABCDEFFEDCBA"

      they all see the auto update to upgrade to 1.4.2_20, which is only available for J4B.

      To reproduce this:

      * install 1.4.2_19 GA
      * then install 1.5.0_18 GA
      * load the attached applet or any applet with

      <HTML>
          <body>
              <OBJECT classid="clsid:CAFEEFAC-0014-0002-FFFF-ABCDEFFEDCBA" width="512" height="243">
                      <PARAM NAME="archive" VALUE="your.jar" >
                      <PARAM NAME="code" VALUE="your.class">
              </OBJECT>
         </body>
      </HTML>

      * And when using IE 6.0, you will see the pop up window when loading the applet complaining that 1.4.2_19 is outdated

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                raginip Ragini Prasad (Inactive)
                Reporter:
                hnassiry Haroon Nassiry (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: