Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6864886

G1: rename -XX parameters related to update buffers

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: hs16
    • Fix Version/s: hs16
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
      gc
    • Resolved In Build:
      b08
    • CPU:
      generic
    • OS:
      generic

      Backports

        Description

        From an e-mail I recently sent:

        I noticed that some G1 parameters are very badly (and inconsistently) named!

        In g1_globals.hpp:

        1) G1DirtyCardQueueMax - maximum update buffer queue length before mutators start processing update buffers

        In globals.hpp:

        2) DCQBarrierQueueBufferSize - length (it's not really size) of the update buffers
        3) DCQBarrierProcessCompletedThreshold - how many update buffers must be in the queue before concurrent refinement threads start processing them

        First, given that 2) and 3) are only used by G1, I think they should get the G1 prefix (and be moved to the g1_globals.hpp file). Second, I'd like to make the parameter names more consistent. These are the proposed new names:

        1) G1UpdateBufferQueueMaxLength
        2) G1UpdateBufferLength
        3) G1UpdateBufferQueueProcessingThreshold

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  tonyp Tony Printezis
                  Reporter:
                  tonyp Tony Printezis
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Imported:
                    Indexed: