Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6872000

G1: compilation fails on linux/older gcc

    XMLWordPrintable

    Details

    • Subcomponent:
      gc
    • Resolved In Build:
      b08
    • CPU:
      generic
    • OS:
      generic
    • Verification:
      Not verified

      Backports

        Description

        When building HotSpot for JDK 6 we're getting the following error:

        src/share/vm/gc_implementation/g1/concurrentMark.cpp: In
           member function `bool CSMarkOopClosure::drain()':
        src/share/vm/gc_implementation/g1/concurrentMark.cpp:2404: parse
           error before `;' token

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                tonyp Tony Printezis
                Reporter:
                tonyp Tony Printezis
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: