Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6879717

J2SE_2D:The printed output of the second set of font is a blank of page on winxppro-x64-sp2.

    XMLWordPrintable

    Details

    • Subcomponent:
      2d
    • CPU:
      x86
    • OS:
      windows_xp

      Description

      JDK/JRE tested:6u18b01
      OS/architecture:WinXPPro-x64-sp2
      Reproducible: Always
      Is it a platform specific regression: N
      Is it a Regression: Not sure
      #case: 2D_Printing/Interactive/PrintFont_2D/PrintFont_2D.java

      #Steps to reproduce:
      The testing involves printing logical and physical fonts using Native dialog
      and None Dialog.
      Please enter the font which is not printed properly.
      1. In the testframe, you will find a list of font names.
      2. Choose 'None Dialog'/ 'Native Dialog' option.
      3. Maximise the test frame to see the list of all the fonts.
      4. Press the 'Print' Button.
      5. Check for the printed output. If the output is the same as visible
      in the screen, proceed to next step, else Press 'Assertion Fail'.
      6(a). Click the 'Next Set' Button. You will find another set of fonts appearing
      on the screen.
      6(b). Click the 'Print' Button.
      7. Check for the printout. Press 'Assertion fail' if the printed output
      differs from that of the screen output, else repeat the step 6(a) and 6(b)
      till you find the button 'Next Set' disabled. Press 'Assertion pass' finally.

      #Expected behavior:
      The printed output of all the fonts is the same as that of the screen output.
      #Actual behavior:
      The printed output of the second set of font is a blank page, while the
      other set of fonts can be printed out correctly.Attachment images.zip is all the
      set of font of the test case.In it ,2.jpg is the second set of the font.

      #Exceptions:
      None

      #Validation:
      1.same config/previous build: Same issue.
      2.same config/pre-previous build:Same issue.
      3.same config/6u10 latest build: Same issue.
      4.same config/6u10 fcs(latest live): Same issue.
      5.same JDK ( test target )/Win vista homebasic-x64: Run normally.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            tonyli Tony Li (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: