Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6880306

Proxy.pac script is bad parsed since JRE 6u15

    Details

    • Subcomponent:
    • Introduced In Version:
    • CPU:
      x86
    • OS:
      windows_xp

      Description

      FULL PRODUCT VERSION :
      java version "1.6.0_16"
      Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
      Java HotSpot(TM) Client VM (build 14.2-b01, mixed mode, sharing)

      ADDITIONAL OS VERSION INFORMATION :
      Microsoft Windows XP [Version 5.1.2600]

      A DESCRIPTION OF THE PROBLEM :
      We have a proxy.pac file set to access URLs in our internal network.

      Since the installation of the JRE 6u15 and next 16, I have a problem.
      Indeed, I launch a SWT client or an applet on my IE8 browser and the proxy.pac script used seems to be bad parsed since the installation of the last JRE 6 build 15 or 16. Consequently, my SWT client is never refreshed even if I deliver new JAR versions and the URLs called in my applets cannot be accessed.

      My colleague has the JRE 6u14 version installed and has no problem. I hadn't no problem with the JRE 6u14 too.


      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      Install JRE 6u14 and launch an applet or a SWT client with a proxy.pac script to access URLs. All is ok at this step.
      Install next the JRE 6u15. Deliver a new version of the SWT client or relaunch applet.


      EXPECTED VERSUS ACTUAL BEHAVIOR :
      EXPECTED -
      The new JARs versions of the SWT client are reloaded and the URLs called during the applet exection are accessible.
      ACTUAL -
      The new JARa version of the SWT client are not reloaded and the URLs called during the applet exection are no longer accessible.

      ERROR MESSAGES/STACK TRACES THAT OCCUR :
      No specific error message, proxy.pac parsing problem and so URL not accessible

      REPRODUCIBILITY :
      This bug can be reproduced always.

      CUSTOMER SUBMITTED WORKAROUND :
        To refresh SWT client JAR, I must use "DIRECT connection" in the JAVA controle panel console.
      For the applet, no workaround.

      Or remover JRE 6u15 or 16 and keep the JRE 6u14 version.

      Release Regression From : 6u14
      The above release value was the last known release where this
      bug was not reproducible. Since then there has been a regression.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dgu Dennis Gu (Inactive)
                Reporter:
                ndcosta Nelson Dcosta (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: