Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6900037

javac should warn if earlier -source is used and bootclasspath not set

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 7
    • Fix Version/s: 7
    • Component/s: tools
    • Subcomponent:
    • Resolved In Build:
      b121
    • CPU:
      generic
    • OS:
      generic
    • Verification:
      Verified

      Description

      The javac compiler has long supported compiling to different source levels. However, as documented in the javac man page and written about elsewhere (http://blogs.sun.com/darcy/entry/how_to_cross_compile_for), setting the source level alone is not sufficient to generate code suitable to run on an earlier version of the platform. The bootclasspath needs to be set to the earlier platform version too.

      To help catch this situation, javac could warn if an earlier -source is used and bootclasspath is *not* set explicitly set.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jjg Jonathan Gibbons
                Reporter:
                darcy Joe Darcy
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: