Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6909759

using JDK 1.6.0_18-ea does not work with GlassFish v3

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: 6
    • Fix Version/s: 1.4.0
    • Component/s: xml
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      h1191
    • CPU:
      generic
    • OS:
      generic
    • Verification:
      Verified

      Backports

        Description

        Today on IRC someone reported they could not get v3 to work (admin console would not come up). They ran into this error:

            Caused by: java.lang.UnsupportedOperationException: Cannot create XMLStreamReader or XMLEventReader from a javax.xml.transform.stream.StreamSource
                at com.sun.xml.internal.stream.XMLInputFactoryImpl.jaxpSourcetoXMLInputSource(XMLInputFactoryImpl.java:285)
                at com.sun.xml.internal.stream.XMLInputFactoryImpl.createXMLStreamReader(XMLInputFactoryImpl.java:145)
                at org.jvnet.hk2.config.ConfigParser.parse(ConfigParser.java:109)
                at org.jvnet.hk2.config.ConfigParser.parse(ConfigParser.java:104)
                at org.jvnet.hk2.config.ConfigParser.parse(ConfigParser.java:100)
                at org.glassfish.admingui.plugin.ConsolePluginService.init(ConsolePluginService.java:121)
                at org.glassfish.admingui.plugin.ConsolePluginService.getIntegrationPoints(ConsolePluginService.java:423)
                at org.glassfish.admingui.common.handlers.PluginHandlers.getIntegrationPoints(PluginHandlers.java:160)
                at org.glassfish.admingui.handlers.ThemeHandlers.getThemeFromIntegrationPoints(ThemeHandlers.java:98)
                ... 47 more

        After spending some time looking into this, I finally found this post after doing a google search (should have done this first):

            http://old.nabble.com/Console-load-error-on-fresh-install-(Cannot-create-XMLStreamReader-...-jaxpSourcetoXMLInputSource)-td26411987.html

        Which showed that using JDK 1.6.0_18-ea (at least on linux) does not work with GlassFish v3. Downgrading to the latest stable release (1.6.0_16) solved that person's problem, it also solved the person's problem on IRC.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                joehw Joe Wang
                Reporter:
                joehw Joe Wang
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: