Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6911368

64-bit Windows - jre CurrentVersion isn't set to the highest version number on the machine

    Details

    • Subcomponent:
    • CPU:
      generic, x86
    • OS:
      windows_vista, windows_7

      Description

      On the 64-bit Windows, HKLM\Software\JavaSoft\Java Runtime Environment\CurrentVersion
      isn't set to the highest jre version number on the machine. Instead, it appears to be set to the latest installed jre version which might be lower version than the one already existed on the system. This can be reproducable on 64-bit Windows systems/ 64-bit jre bundles

      Steps to reproduce
      ------------------

      64-bit Windows systems:

      1) Install 64-bit jre 6u18-b06
      2) Install 64-bit jre 1.5.0_22 b03

      if HKLM\Software\JavaSoft\Java Runtime Environment\CurrentVersion has the value "1.5" then the issue is reproducible.
      As the result after step #2 above, you can't do execute java -version from the command line. In fact, you will encouter the registry error as:
      Registry key 'Software\JavaSoft\Java Runtime Environment\CurrentVersion' has value '1.5', but '1.6' is required.
      Error: could not find java.dll
      Error: could not find Java SE Runtime Environment.











      Testsuite name: Install/Removal
      JDK/JRE tested: 6u18b06 64bit
      OS/architecture: windows7-homepremium-rtm-x64
      Reproducible: Always
      Reproducible on machine:
      [If sometimes] Also reproducible on machine:
      Is it a platform specific regression: N
      [If yes] Is it a new platform support: Y/N
      [If yes] Regression relative to OS version:
      Is it a Regression: Not sure
      [If yes] Regression introduced in release/build:
      [If yes] Test result on FCS: Pass/Fail
      Test result on FCS: Fail
      Test run log location:

      Steps to reproduce:
      1.install jre6u18b06-x64.exe
      2.check [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment], check "CurrentVersion",it is with value of "1.6".
      3.install jre5u22b03-x64.exe,check "CurrentVersion",it is with value of "1.5".
      4.execute command in command line: java -version

      Actual results:
      It shows the error info below in command line,
      Registry key 'Software\JavaSoft\Java Runtime Environment\CurrentVersion' has value '1.5', but '1.6' is required.
      Error: could not find java.dll
      Error: could not find Java SE Runtime Environment.

      But for 32bit jre bunld,the "CurrentVersion" is with value of "1.6".

      This issue only against 64bit bundle with Windows platform.

      Pls refer to the picture attached which named of 'jre6u18b06_downgrade.jpg'.

        Attachments

          Activity

            People

            • Assignee:
              raginip Ragini Prasad (Inactive)
              Reporter:
              tonyli Tony Li
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: