Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6938389

Java Web Start 6 is unable to interpret proxy.pac file correctly when app is run on JRE 1.4.2

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Not an Issue
    • Affects Version/s: 6u18
    • Fix Version/s: 6-pool
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • CPU:
      x86
    • OS:
      windows_xp

      Backports

        Description

        Java Web Start 6 Update 18 is used to launch a Java Web Start application,
        that requires to be run on JRE 1.4.2:

            <j2se version="1.4" java-vm-args="-client"/>

        An automatic proxy file (proxy.pac) is not interpreted correctly, when the
        application is started via jnlp file:

              javaws.exe app.jnlp
        or
              javaws.exe /path/to/app.jnlp

        When using Java Web Start 6 with an URL however, the correct proxy
        is picked and everything works as expected.

             javaws.exe http://server:port/app.jnlp
        or
             javaws.exe file:\/\/c:\/app.jnlp

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  coffeys Sean Coffey
                  Reporter:
                  thlenz Thomas Lenz (Inactive)
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Imported:
                    Indexed: