Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-7009942

RFE to prevent security warning "The application requires an earlier version of Java"

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: P4
    • Resolution: Duplicate
    • Affects Version/s: 6u20
    • Fix Version/s: None
    • Component/s: deploy
    • Subcomponent:
    • CPU:
      x86
    • OS:
      windows_xp

      Description

      This is a request to implement at Java Contol Panel a option to manually disable
      the security Warning "The application requires an earlier version of Java".

      This Message comes up, when a Java Applet is defined to explicit use
      a specific Java Version, but a newer JRE is already installed at the system.

      Steps to reproduce.
      Install silent these two JRE's at a clean Windows XP System:
      jre-6u23-windows-i586.exe /s INSTALLDIR=C:\java\jre6u23 STATIC=1
      jre-6u20-windows-i586.exe /s INSTALLDIR=C:\java\jre6u20 STATIC=1

      Sample html for the applet object.
      <object
        classid="clsid:CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA"
        width="200" height="200" >
        <param name="code" value="ShowJavaVersionApplet.class">
      </object>

      call this page from any browser, a message comes up like:
      The application requires an earlier version of Java. Do you want to continue?
      [ Run] [Cancel]

      Related Oracle Enhancement Request
      Bug 10282035 - OPT TO DISABLE THE MESSAGE "THE APPLICATION REQUIRES AN EARLIER VERSION OF JAVA"

        Attachments

          Activity

            People

            Assignee:
            herrick Andy Herrick
            Reporter:
            arieck Andreas Rieck (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: