Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-7053559

REGRESSION:JNI wrapper broken in 6u26 on Windows 7

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      windows_7

      Description

      J2SE Version (please include all output from java -version flag):
      java version "1.6.0_26"

      Does this problem occur on J2SE 1.4.x, 1.5 or 6? Yes / No (pick one)
      No, worked fine with 6u25.


      Operating System Configuration Information (be specific):
      Windows 7 32 bit. Windows XP works ok


      Hardware Configuration Information (be specific):
      Tested on i386

      Bug Description:
       the latest official JDK/JRE (1.6.0_26) has broken something really basic with jni.
       It shows at least on Windows 7 32 bit. Windows XP works ok.

       What happens for end users is that the "Add images" button inside our desktop
       software jAlbum (http://jalbum.net/software)
       no longer works. Nothing happens. This is almost the most important button in the
       whole program,
      so for us, this bug is VERY severe. I've traced it down to the
       following JNI call:

        public native byte[][] getFiles2();

      That call belongs to net.tomahawk.XFileDialog, a Java JNI wrapper for Windows native
      file dialog.
      We use this wrapper so our users can select multiple images and see
      thumbnails as they do multiple
      image selection from their file system. The Swing
      alternative is too outdated and doesn't blend
      with the Windows 7 experience, so
      we're forced to use this workaround. Now it doesn't work anymore
      and we get no
      error at all from this call. When it works, it should pop up the Windows file
      dialog,
      but now nothing happens. I can add that the maker of this wrapper has
      abandoned it so we can't
      get any support from him.

      What jni related changes have been introduced in 1.6.0_26 that may cause this?
      It worked fine on earlier versions.

      Appreciate a quick response to this, cause at the moment, this bug hurts our
      business a lot!


      Simply download jAlbum(http://jalbum.net/software) on Windows 7 and press the "Add" button to confirm the problem.
      Attached x.filedialog.jar and .dll test library files.

      Here is also a code snippet for how interact with this API,
      that should trigger the problem:

      import net.tomahawk.XFileDialog;
      ...
      XFileDialog dlg=new XFileDialog((Frame)parent);
      dlg.setThumbnail(true);
      dlg.setTitle("Add images");
      dlg.setDirectory(currentDir.getAbsolutePath());
      String[] filenames = dlg.getFiles(); // Returns without opening dialog. Should normally open a modal dialog and wait for user response
      Closed as Duplicate of 7056092. Updated the RE / RM to that of 7056092.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dcherepanov Dmitry Cherepanov
                Reporter:
                tyao Ting-Yun Ingrid Yao (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: