Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-7091394

packages runtime/java/jre-6 and developer/java/jdk-6 miss dependency on X packages

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Cannot Reproduce
    • Affects Version/s: solaris_11
    • Fix Version/s: 6u34
    • Component/s: install
    • Labels:
    • Subcomponent:
    • CPU:
      generic
    • OS:
      solaris_nevada

      Description

      During SST snv_2011-09-12(RE) nightly testing of we've found that packages runtime/java/jre-6 and developer/java/jdk-6 contain files having runtime dependency on X packages, which is not stated in IPS package dependencies.

      Problem affects both x64 and sparc packages.

      Package developer/java/jdk-6 should depend on x11/library/libx11.

      Package runtime/java/jre-6 should depend on:
        x11/library/libdga
        x11/library/libx11
        x11/library/libxext
        x11/library/libxi
        x11/library/libxtst
        x11/library/toolkit/libxt

      Sample .so file declaring runtime dependency:
      ldd /usr/jdk/instances/jdk1.6.0/jre/lib/amd64/libsplashscreen.so
              libsplashscreen.so
              libX11.so.4 => /usr/lib/64/libX11.so.4
              libXext.so.0 => /usr/lib/64/libXext.so.0
              libXau.so.6 => /usr/lib/amd64/libXau.so.6
              libXdmcp.so.6 => /usr/lib/amd64/libXdmcp.so.6
              libXevie.so.1 => /usr/lib/amd64/libXevie.so.1
              libXss.so.1 => /usr/lib/amd64/libXss.so.1

      Files declating runtime dependency on x64 machines:

      usr/jdk/instances/jdk1.6.0/jre/lib/i386/libjavaplugin_jni.so
      usr/jdk/instances/jdk1.6.0/jre/lib/i386/libjavaplugin_nscp.so
      usr/jdk/instances/jdk1.6.0/jre/lib/i386/libsplashscreen.so
      usr/jdk/instances/jdk1.6.0/jre/lib/i386/libsunwjdga.so
      usr/jdk/instances/jdk1.6.0/jre/lib/i386/xawt/libmawt.so
      usr/jdk/instances/jdk1.6.0/jre/plugin/i386/ns4/libjavaplugin.so
      usr/jdk/instances/jdk1.6.0/jre/plugin/i386/ns7/libjavaplugin_oji.so
      usr/jdk/instances/jdk1.6.0/jre/lib/amd64/libsplashscreen.so
      usr/jdk/instances/jdk1.6.0/jre/lib/amd64/xawt/libmawt.so

      java/jre-6 package dependencies:

      pkg contents -m runtime/java/jre-6|grep depend
      depend fmri=consolidation/ub_javavm/ub_javavm-incorporation type=require
      depend fmri=system/###@###.###65 type=require
      depend fmri=system/library/c++###@###.### type=require
      depend fmri=system/###@###.###65 type=require
      depend fmri=shell/###@###.### type=require
      depend fmri=system/library/###@###.### type=require
      depend fmri=library/###@###.### type=require

        Attachments

          Activity

            People

            Assignee:
            miroslawzn Miroslaw Niemiec (Inactive)
            Reporter:
            vhrachov Vít Hrachový
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: