Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-7102635

SSV2:"Allow using insecure JRE versions" option doesn't work for non-jnlp based applets in plugin

    Details

    • Subcomponent:
    • Resolved In Build:
      b10
    • CPU:
      generic
    • OS:
      generic
    • Verification:
      Verified

      Backports

        Description

        Desc:
         If 7u2 deactivate old releases feature option
          "Insecure JRE versions" is set to "Allow using insecure JRE versions ..."
          applet requesting old insecure JRE version ( installed ) should be executed with this JRE
          without new security warning window "An application would like access to an old version of Java".

          In fact it works OK for javaws apps, but doesn't work for applets, security warning always appears.
          See details and applets links to reproduce in comments.
        also see: 7102791
        simple fix in canDownload will be included with this fix
        see also : 7102635
        there is no permanant store to record this decision, however we can keep this info session wide (so you can reload the app, or come to same app on a differant tab).
        this fix will be included as part of 7102635, closing 7102635 as a supe of this.

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  herrick Andy Herrick
                  Reporter:
                  dgubkin Dmitriy Gubkin (Inactive)
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Imported:
                    Indexed: