Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-7102652

SSV2: on the second run for a non-jnlp applet, ssv2 security warning is shown again in plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Duplicate
    • Affects Version/s: 7u2
    • Fix Version/s: None
    • Component/s: deploy
    • Labels:
      None
    • Subcomponent:
    • CPU:
      generic
    • OS:
      generic

      Description

      Desc:
        it's expected that applet requiesting old JRE won't cause security warning
       ( "An application would like access to an old version of Java" ) on the second run
        if on the first run permission to run with old JRE has been given.

       But in fact on the second run we get the same security warning for all cases below:
         - for second run in another browser tab
         - for applet reloading using "refresh" button
         - for complete browser restart and applert rerun

        All works as expected in case of javaws application.
        "Insecure JRE versions" option is set to "Prompt user before using insecure JRE versions"

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              herrick Andy Herrick (Inactive)
              Reporter:
              dgubkin Dmitriy Gubkin (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: