Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-7138656

Java applets do not work on my computer because of the JRE 1.7

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      windows_xp

      Description

      FULL PRODUCT VERSION :
      JRE 1.7 and JRE 1.6

      ADDITIONAL OS VERSION INFORMATION :
      MS Windows XP

      A DESCRIPTION OF THE PROBLEM :
      I have installed both JRE 1.7 update 4 and JRE 1.6 update 30. The problem is that I can not run any Java app in my browser (Chrome or Opera). Chrome says that Java is not installed (yep, I tried to reinstall - didn't work), Opera gave an error that web site is running Java 1.6 and opera tried to run with java 1.7 and it crashed. The question is why chrome and opera do not use Java 1.6 instead of that buggy 1.7 which is not backwards compatible.

       And I can not uninstall Java 1.7 because I need it to run my own application created with Eclipse using Java 1.7.



      REGRESSION. Last worked in version 6u29

      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      Using WIndows XP install Java 1.7 and Java 1.6. Try to run web based java application. Thats all.

      EXPECTED VERSUS ACTUAL BEHAVIOR :
      EXPECTED -
      Running java applet in any page.
      ACTUAL -
      Java applications do not work in Chrome and in Opera and Chrome doesn't recognize it has java installed.

      ERROR MESSAGES/STACK TRACES THAT OCCUR :
      Java Plug-in 1.6.0_30
      Using JRE version 1.7.0_04-ea-b06 Java HotSpot(TM) Client VM
      User home directory = C:\Documents and Settings\Bendras
      ----------------------------------------------------
      c: clear console window
      f: finalize objects on finalization queue
      g: garbage collect
      h: display this help message
      l: dump classloader list
      m: print memory usage
      o: trigger logging
      q: hide console
      r: reload policy configuration
      s: dump system and deployment properties
      t: dump thread list
      v: dump thread stack
      x: clear classloader cache
      0-5: set trace level to <n>
      ----------------------------------------------------


      java.lang.ExceptionInInitializerError
      at com.sun.deploy.net.protocol.https.Handler.openConnection(Unknown Source)
      at java.net.URL.openConnection(Unknown Source)
      at sun.net.www.protocol.jar.JarURLConnection.&lt;init&gt;(Unknown Source)
      at sun.plugin.net.protocol.jar.CachedJarURLConnection.<init>(Unknown Source)
      at sun.plugin.net.protocol.jar.Handler.openConnection(Unknown Source)
      at java.net.URL.openConnection(Unknown Source)
      at com.sun.deploy.security.DeployURLClassPath$JarLoader.getJarFile(Unknown Source)
      at com.sun.deploy.security.DeployURLClassPath$JarLoader.access$1000(Unknown Source)
      at com.sun.deploy.security.DeployURLClassPath$JarLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at com.sun.deploy.security.DeployURLClassPath$JarLoader.ensureOpen(Unknown Source)
      at com.sun.deploy.security.DeployURLClassPath$JarLoader.<init>(Unknown Source)
      at com.sun.deploy.security.DeployURLClassPath$3.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at com.sun.deploy.security.DeployURLClassPath.getLoader(Unknown Source)
      at com.sun.deploy.security.DeployURLClassPath.getLoader(Unknown Source)
      at com.sun.deploy.security.DeployURLClassPath.getResource(Unknown Source)
      at sun.plugin2.applet.Plugin2ClassLoader$2.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at sun.plugin2.applet.Plugin2ClassLoader.findClassHelper(Unknown Source)
      at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
      at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
      at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
      at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
      at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
      at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
      at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
      at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.ClassCastException: sun.security.ssl.X509TrustManagerImpl cannot be cast to com.sun.net.ssl.internal.ssl.X509ExtendedTrustManager
      at com.sun.deploy.security.X509ExtendedDeployTrustManager.<init>(Unknown Source)
      at com.sun.deploy.net.protocol.https.Handler$Initializer$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at com.sun.deploy.net.protocol.https.Handler$Initializer.<clinit>(Unknown Source)
      ... 31 more
      Exception: java.lang.ExceptionInInitializerError


      REPRODUCIBILITY :
      This bug can be reproduced always.

      CUSTOMER SUBMITTED WORKAROUND :
      Uninstalling JRE 1.7. But as I said before I need 1.7 to run my own application. Yes, I could have created my app using JDK 1.6 but that is not the point.

        Attachments

          Activity

            People

            • Assignee:
              ngthomas Thomas Ng (Inactive)
              Reporter:
              webbuggrp Webbug Group
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Imported:
                Indexed: