Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8000997

Multiple locale sensitive services cannot be loaded

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 8
    • Fix Version/s: 8
    • Component/s: core-libs
    • Labels:
    • Subcomponent:
    • Introduced In Build:
      b55
    • Introduced In Version:
      8
    • Resolved In Build:
      b64
    • CPU:
      generic
    • OS:
      generic

      Description

      With the locale data deployment feature, locale sensitive services SPI implementations cannot be loaded more than one implementation. This is due to the fact that SPILocaleProviderAdapter only uses one instance of SPI implementations. It should load all the available installed providers as in JDK7, and correctly selects the instance depending on the requester's locale.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                naoto Naoto Sato
                Reporter:
                naoto Naoto Sato
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: