Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8003323

java can't be enabled on expired jre on linux

    Details

      Description

      Test env: 32bit ubuntu 12, jre 7u10 b15

      Steps to reproduce
      - install and register jre on browser
      - modify system time to be 5 years later to make the jre expired
      - launch test applet http://rehte.cn.oracle.com:8080/wshost/new_framework/new_framework/tests/plugin/manual/ExpiredJREJPI/html/requestLatestJREUnsigned.html
      - click block on the "update/block/later" dialog
      - enable java on security tab on jcp
      - relaunch the applet, if applet is still blocked, bug is reproduced. when launching firefox from command line, after loading applet, following msg is printed.
      "Disabling Java as it is too old and likely to be insecure. To reenable use jcontrol utility"

        Attachments

          Activity

            People

            • Assignee:
              jijising Jitender Singh (Inactive)
              Reporter:
              qgong Fred Gong (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: