Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8007762

Rename a bunch of methods in size policy across collectors

    Details

    • Subcomponent:
      gc
    • Resolved In Build:
      b35

      Backports

        Description

        The motivation of this change is associated with JDK-7098155. For this, we need to split compute_generations_free_space into two routines (one for compute_eden_space_size and the other for compute_old_gen_free_space) in order to save some overhead when we want to compute only one of the two (JDK-8007763).

        To unify the naming, a bunch of routines are renamed here.
        (1) rename compute_generation_free_space() to compute_generations_free_space() to reflect its complexity
        (2) compute_*: (for the sake of symmetry)
              compute_survivor_space_size_and_threshold()
              compute_generations_free_space() = compute_eden_space_size() + compute_old_gen_free_space()
        (3) necessarily update some logging message text

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  tamao Tao Mao (Inactive)
                  Reporter:
                  tamao Tao Mao (Inactive)
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: