Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8008949

javadoc stopped copying doc-files

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 8
    • Fix Version/s: 8
    • Component/s: tools
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b82
    • Verification:
      Verified

      Backports

        Description

        From Uwe Schindler uschindler at apache.org

        - Source folders named "doc-files" are no longer copied to the output, so our Javadocs are now missing additional images and other additional HTML files, that were placed there to be included into the javadocs. We have our own "linting" for javadocs based on HTMLtidy and a python script, so we noticed this error very soon (and our Jenkins builds fail).

          Issue Links

            Activity

            jjg Jonathan Gibbons added a comment -
            Side effect of converting javadoc to support JSR 199, and the DocFile conversion.

            The cause is that the DocFileFactory was using an incompletely initialized file manager, so the source path was defaulting to the class path, which was also not set.

            The underlying cause is that DocFileFactory was inited too early, so it created/used a default file manager, different from the one used for RootDocImpl. This is because the code *created* the output directory as a *side*effect* of checking the "-d" option.

            Fix is to defer creating the output directory until a more suitable time (in setOptions).
            hgupdate HG Updates added a comment -
            URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/6f988040a1c8
            User: jjg
            Date: 2013-03-01 19:35:21 +0000
            hgupdate HG Updates added a comment -
            URL: http://hg.openjdk.java.net/jdk8/jdk8/langtools/rev/6f988040a1c8
            User: lana
            Date: 2013-03-15 16:28:01 +0000

              People

              • Assignee:
                jjg Jonathan Gibbons
                Reporter:
                jjg Jonathan Gibbons
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: