Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8011044

Remove support for 1.5 and earlier source and target options

    Details

    • Subcomponent:
    • Resolved In Build:
      b23
    • CPU:
      generic
    • OS:
      generic
    • Verification:
      Verified

      Description

      Support for javac source and target options for the 1.5 platform and earlier should be removed.

        Issue Links

          Activity

          Hide
          darcy Joe Darcy added a comment -
          See:
          JEP 182: Policy for Retiring javac -source and -target Options
          http://openjdk.java.net/jeps/182
          Show
          darcy Joe Darcy added a comment - See: JEP 182: Policy for Retiring javac -source and -target Options http://openjdk.java.net/jeps/182
          Hide
          ntoda Neil Toda added a comment -
          ccc 8011044 - Approved.
          2014-01-09 11:48:21 state approved
          Show
          ntoda Neil Toda added a comment - ccc 8011044 - Approved. 2014-01-09 11:48:21 state approved
          Hide
          ntoda Neil Toda added a comment -
          langtools tests cover all these changes.
          Show
          ntoda Neil Toda added a comment - langtools tests cover all these changes.
          Hide
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk9/dev/langtools/rev/fbfbefa43016
          User: jjg
          Date: 2014-07-10 20:57:32 +0000
          Show
          hgupdate HG Updates added a comment - URL: http://hg.openjdk.java.net/jdk9/dev/langtools/rev/fbfbefa43016 User: jjg Date: 2014-07-10 20:57:32 +0000
          Hide
          darcy Joe Darcy added a comment -
          The javac command no longer support -source or -target options below 6/1.6. However, older class files are still readable by javac. Source code for older release can be ported to the newer source level. To generate class files usable by older release, a javac from a previous release train can be used.
          Show
          darcy Joe Darcy added a comment - The javac command no longer support -source or -target options below 6/1.6. However, older class files are still readable by javac. Source code for older release can be ported to the newer source level. To generate class files usable by older release, a javac from a previous release train can be used.
          Hide
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk9/jdk9/langtools/rev/fbfbefa43016
          User: lana
          Date: 2014-07-16 16:40:02 +0000
          Show
          hgupdate HG Updates added a comment - URL: http://hg.openjdk.java.net/jdk9/jdk9/langtools/rev/fbfbefa43016 User: lana Date: 2014-07-16 16:40:02 +0000

            People

            • Assignee:
              ntoda Neil Toda
              Reporter:
              darcy Joe Darcy
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: