Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8016002

Rename periodUntil() to until()

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 8
    • Fix Version/s: 8
    • Component/s: core-libs
    • Labels:
    • Subcomponent:
    • Introduced In Version:
      8
    • Resolved In Build:
      b102
    • CPU:
      generic
    • OS:
      generic
    • Verification:
      Verified

      Description

      The Temporal.periodUntil and ChronoLocalDate.periodUntil methods use the name "period", but we only use that for date-based now via the Period class. The general term is "amount", but renaming to amountUntil() wouldn't be entirely clear. Renaming to until() is simple and effective, and keeps the methods grouped in the IDE.

      See Github issud #311 https://github.com/ThreeTen/threeten/issues/311

        Attachments

          Activity

            People

            • Assignee:
              rriggs Roger Riggs
              Reporter:
              rriggs Roger Riggs
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: