Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8023322

Need to update makefile when official compiler switches to SS12u3

    Details

    • Subcomponent:
    • OS:
      solaris

      Description

      We need changes in the makefiles to update the official compiler version so that use of S12u3 doesn't produce warnings.

      make/solaris/makefiles/sparcWorks.make

      # Pick which compiler is validated
      ifeq ($(JRE_RELEASE_VER),1.6.0)
        # Validated compiler for JDK6 is SS11 (5.8)
        VALIDATED_COMPILER_REVS := 5.8
        VALIDATED_CC_COMPILER_REVS := 5.8
      else
        # Validated compiler for JDK7 is SS12 update 1 + patches (5.10)
        VALIDATED_COMPILER_REVS := 5.10
        VALIDATED_CC_COMPILER_REVS := 5.10
      endif


      Of course now we don't have hotspot express we can scrap the entries for JDK 6 and 7.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              dholmes David Holmes
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: