Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8023897

Replace/update/rename executeAndCatch in various tests to assertThrows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 8
    • Fix Version/s: 9
    • Component/s: core-libs
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b169

      Backports

        Description

        Many tests (see Spliterator test especially) use a function executeAndCatch which essentially asserts that an exception is thrown. Change the name to assertThrows and/or copy assertThrows used in other tests.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                amlu Amy Lu (Inactive)
                Reporter:
                psandoz Paul Sandoz
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: