Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8023957

Lock down version of autoconf

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 8
    • Fix Version/s: 8
    • Component/s: infrastructure
    • Labels:
      None
    • Subcomponent:
    • Resolved In Build:
      b106
    • CPU:
      generic
    • OS:
      generic

      Description

      Currently three different versions of autoconf are commonly used to update generated-configure.sh, 2.67, 2.68 and 2.69. We should decide on a version and stick to it. From discussion on the open list it seems locking it to 2.69 would be acceptable by everyone. The easiest way to achieve this is to simply change the AC_PREREQ macro to require this minimum version. Perhaps we should also make sure no newer version is used either.

      By fixing this we can also remove the 2.67 workaround in autogen.sh that is there today.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              erikj Erik Joelsson
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: