Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8024756

method grouping tabs are not selectable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: 8
    • Fix Version/s: 8
    • Component/s: tools
    • Labels:
    • Environment:

      windows/Chrome

    • Subcomponent:
    • Introduced In Version:
      8
    • Resolved In Build:
      b112
    • Verification:
      Verified

      Backports

        Description

        Can't select and view contents of method grouping tabs on windows with Chrome.
        How to reproduce:
        1. Download JDK Docs bundle from http://jdk8.java.net/download.html and unzip it.
        2. Open doc/api/index.html using Chrome (using v.29)
        3. "All Method" tab is selected by default.
        4. Try to select any other tabs, but no any respond.

        It works with FF and IE

        Effected tests below with jdk8 from http://wiki.se.oracle.com/display/JPG/JavaDocOptionalGrouping+Test+cases:
        javadoc/OptionalGrouping/Class_A
        javadoc/OptionalGrouping/Class_B
        javadoc/OptionalGrouping/Class_C
        javadoc/OptionalGrouping/Class_D

          Activity

          mtrudeau Michel Trudeau added a comment -
          This is reproducible on Windows 8.
          bpatel Bhavesh Patel added a comment -
          The issue here is not with the method grouping tabs but with the Javascript which sets the window title. The script fails while accessing the API file as a local file in Chrome due to Chrome's same-origin policy where a frame is not able to set the title of the main window. This results in an error and halts the further execution of Javascript which has the method tab grouping code. Hence, the tabs are not selectable.
          The fix for this is to have a try catch block around the Javascript for the window title so the error will be caught and the Javascript will execute further and enable the method grouping tabs code.
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/3344ea7404b1
          User: bpatel
          Date: 2013-10-04 20:41:50 +0000
          hgupdate HG Updates added a comment -
          URL: http://hg.openjdk.java.net/jdk8/jdk8/langtools/rev/3344ea7404b1
          User: lana
          Date: 2013-10-11 17:38:51 +0000

            People

            • Assignee:
              bpatel Bhavesh Patel
              Reporter:
              lshikhva Ludmila Shikhvarg
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved: