Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8026281

hotspot 'jdk6_or_earlier logic' for FDS needs to be removed

    Details

    • Subcomponent:
    • CPU:
      generic
    • OS:
      generic

      Description

      This issue came up during the code review cycle for JDK-7165611. The comment
      below is for the BSD/MacOS X Makefiles, but the 'jdk6_or_earlier logic' also exists
      for other platforms.

      > - make/bsd/makefiles/defs.make
      >
      > Note that the whole jdk6_or_earlier logic is defunct as this will never be used for jdk6 or earlier. But best to clean all that up at the one time.

      Agreed that we (Oracle) currently don't have plans to drop HSX-25 into
      JDK6 or OpenJDK6, but I don't want to rule out future insanity.

      Also agreed that cleaning up that logic should all be done at the same
      time using a different bug ID.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                dcubed Daniel Daugherty
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: