Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8026796

Make replace_in_map() on parent maps generic

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: hs25, 8u40
    • Fix Version/s: 9
    • Component/s: hotspot
    • Subcomponent:
    • Resolved In Build:
      b20

      Backports

        Description

        The change of 8024069 only works in a limited set of cases

          Issue Links

            Activity

            hgupdate HG Updates added a comment -
            URL: http://hg.openjdk.java.net/jdk9/hs-comp/hotspot/rev/e38bb04f030d
            User: roland
            Date: 2014-06-10 13:23:43 +0000
            roland Roland Westrelin added a comment -
            Regarding lack of regression test: this change affects quality of compiled code and as every similar change is harder to test.
            hgupdate HG Updates added a comment -
            URL: http://hg.openjdk.java.net/jdk9/jdk9/hotspot/rev/e38bb04f030d
            User: lana
            Date: 2014-06-20 17:39:40 +0000
            kvn Vladimir Kozlov added a comment -
            Consider to backport this changes to 8u so that 8u and 9 C2 code is more consistent.
            kvn Vladimir Kozlov added a comment -
            8u is affected because 8024069 was backported into jdk8.

              People

              • Assignee:
                roland Roland Westrelin
                Reporter:
                roland Roland Westrelin
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: