Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Duplicate
    • Affects Version/s: 7u51
    • Fix Version/s: None
    • Component/s: deploy
    • Labels:
    • Introduced In Version:
    • CPU:
      generic
    • OS:
      generic

      Description

      Further work is needed on the UI for Exception Site List:

      Tried this UI and misread "Click Add to add an item to this list" as "Click to add an item to this list". Given that this text looks like a JTable entry, then tried in-place text editing of the entry. Given that the text looks just like a list entry and some UI's work by letting you click on the first entry and then automatically clearing the help text for you, it may confuse others.

      Beyond that point, however:

          * The Add button often doesn't start the in-place Location editor on the new entry.
              o It works fine in some cases, but not in many others, e.g. when the entry being added is the very first entry as well as others that didn't figure out how to reproduce.

          * Managed to get the UI into a state where after removing an entry where it wouldn't let me select further entries for removal -- or even hit OK.
              o It seems this happens when you hit "Remove" while the in-place editor on the entry in question is active.

          * lso managed to get text entry to work yet show only 1 character at a time of what was typing -- not sure how as only managed this once.

          * The UI table doesn't look like a normal JTable. It looks like there is an extra text field outline around each URL. That's not a big deal -- it's just ugly.
               o It does make me wonder whether some of the other issues noted are due to attempts at complex event handling around HTTP vs. HTTPS, though.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                herrick Andy Herrick
                Reporter:
                tyao Ting-Yun Ingrid Yao (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: