Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8032627

Add @SuppressWarnings("serial") to appropriate javax.swing classes

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: client-libs
    • Labels:

      Description

      Many classes in javax.swing have a warning stating "Serialized objects of this class will not be compatible with future Swing releases." Such types should be @SuppressWarnings("serial") so that a warning is not issued when these classes lack a serialVersionUID field.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                darcy Joe Darcy
                Reporter:
                darcy Joe Darcy
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: