Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8033705

Array out of bounds exception in PluginMain.performSSVValidation

    Details

    • Subcomponent:
    • Resolved In Build:
      b08
    • Verification:
      Not verified

      Backports

        Description

        there is the following code in performSSVValidation:
                   int dashIndex1 = selectedVersion.indexOf("-");

                    if (dashIndex1 != -1) {
                        // ignore anything after '-' in the version
                        // e.g 1.8.0-ea becomes 1.8.0
                        selectedVersion = selectedVersion.substring(0, dashIndex);
                    }
        The problem is the typo in the last line to use dashIndex instead of dashIndex1.
        This is within the scope of dashIndex, which is used above on the "runningVersion" where this is the "selectedVersion"

        If (for example) selectedVersion is "1.7.0_55-internal" and runningVersion is "1.7.0_55" this will cause an exception.

        I found this with the internal version in my path, running jcontrol (puts it in the properties file), then ran tck test pointing javaws executable at final "1.7.0_55" (putting it second in list in deployment.properties) then ran test jnlp_file/appletDesc.

        can probably be reproduced using two unregistered versions, one internal and one fcs and running any appletDesc jnlp file thru java web start.

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  vdrozdov Victor Drozdov (Inactive)
                  Reporter:
                  herrick Andy Herrick
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Due:
                    Created:
                    Updated:
                    Resolved: