Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8035053

Missing resources.jar configuration info for AppleScript scripting support

    Details

      Description

      FULL PRODUCT VERSION :
      java version "1.7.0_51"
      Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
      Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

      ADDITIONAL OS VERSION INFORMATION :
      Darwin localhost 12.5.0 Darwin Kernel Version 12.5.0: Sun Sep 29 13:33:47 PDT 2013; root:xnu-2050.48.12~1/RELEASE_X86_64 x86_64

      EXTRA RELEVANT SYSTEM CONFIGURATION :
      None relevant I know of.

      A DESCRIPTION OF THE PROBLEM :
      In resources.jar
      META-INF/services/javax.script.ScriptEngineFactory
      is missing a AppleScript entry on OS X.

      Should look something like...


      #script engines supported

      com.sun.script.javascript.RhinoScriptEngineFactory #javascript
      apple.applescript.AppleScriptEngineFactory #AppleScriptEngine



      REGRESSION. Last worked in version 7u25

      ADDITIONAL REGRESSION INFORMATION:
      It did used to work at some point. But I'm not sure of the exact release it stopped. Maybe the problem turned up because some Apple related got removed. I started testing at _40 and it didn't work there. It did on a 10.7 Mac though.

      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      jrunscript -q
      AppleScript will be missing

      jrunscript -q
      Language ECMAScript 1.8 implemention "Mozilla Rhino" 1.7 release 3 PRERELEASE

      EXPECTED VERSUS ACTUAL BEHAVIOR :
      EXPECTED -
      AppleScript to be present

      Language AppleScript 2.2.4 implemention "AppleScriptEngine" 1.1
      Language ECMAScript 1.8 implemention "Mozilla Rhino" 1.7 release 3 PRERELEASE
      ACTUAL -
      jrunscript -q
      Language ECMAScript 1.8 implemention "Mozilla Rhino" 1.7 release 3 PRERELEASE

      REPRODUCIBILITY :
      This bug can be reproduced always.

      ---------- BEGIN SOURCE ----------
      see jrunscript
      ---------- END SOURCE ----------

      CUSTOMER SUBMITTED WORKAROUND :
      I updated resources.jar as shown and it worked.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                serb Sergey Bylokhov
                Reporter:
                webbuggrp Webbug Group
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: