Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8035058

"Don't ask again..." doesn't work for expired native dialog on Ubuntu

    Details

    • Subcomponent:
    • Resolved In Build:
      b08
    • Verification:
      Verified

      Backports

        Description

        test ENV:
        Ubuntu/x86/jre8-b129

        Steps to reproduce:
        1.Instal test jre 8-b129
        2.Move system date to 5 years later(if current year is 2012 move it to 2017).
        3.Clear cache: javaws -uninstall
        4.Load following app from CMD: javaws http://sqeweb.us.oracle.com/net/sqenfs-1/export1/comp/jsn/users/crystal/DO_NOT_REMOVE_ME/jrebug/ExpiredJREJW/jnlp/testSelfSignedRequestLatest.jnlp
        5.There should be a native dialog with warning that java version is out of date should appear. The dialog is with update, block or later button. Click "later" to proceed and check the checkbox don't ask again.
        6.Test application should get blocked.
        7.Relaunch the application
        8. If the native dialog shows up again, then this bug is reproduced.

        Expected behavior:
        The native dialog should not appear in step#8 and the applicaiton should get blocked again.

        Note: there is no such issue on windows platform.

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  vdrozdov Victor Drozdov (Inactive)
                  Reporter:
                  wenjyang Crystal Yang
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: