Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8038473

Remove support for old T1 libthread

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: hotspot
    • Subcomponent:
    • Resolved In Build:
      b10
    • OS:
      solaris

      Description

      Hotspot still has the code to use either T1 or T2 libthread in Solaris. T1 libthread has been removed from Solaris in release 10. JDK9 requires Solaris 10u9 or higher. It's time to remove the T1 libthread support.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                fparain Frederic Parain
                Reporter:
                fparain Frederic Parain
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: