Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8039261

[TEST_BUG]: There is not a minimal security level in Java Preferences and the TestApplet.html is blocked.

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b18
    • CPU:
      x86_64

      Backports

        Description

        Testsuite name: Regression
        JDK/JRE tested: JDK8u20b07(64bit)
        OS/architecture: oel6.4-uek-x64
        Reproducible: Always
        Reproducible on machine: oel6.4-uek-x64

        Instruction:
        (1) Install the tested JDK to be used by the Java Plugin.
        (2) Open Java Preferences and set security level to minimal.
        (3) Open the TestApplet.html in Firefox in firefox web browser. It is located at:
        /workspace/regression/results/workDir/classes/java/awt/event/KeyEvent/KeyReleasedInAppletTest
        (5) Continue the test according to the instructions in the applet.

        Actual behavior:
         For step(2):There is no minimal security level in Java Preferences refer to controlpanel.jpg.
         For step(3):The 'Java Application Blocked' dialog appear when we open the TestApplet.html in Firefox refer to block.jpg.

        Validation:It has same issue from 8u20b05(64bit).

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                azvegint Alexander Zvegintsev
                Reporter:
                tolli Tony Li (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                12 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: