Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8039525

HashTables lookup API needs refactoring

    Details

    • Type: Enhancement
    • Status: Closed
    • Priority: P4
    • Resolution: Won't Fix
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • CPU:
      generic
    • OS:
      generic

      Description

      HashTables lookup API needs refactoring

      "lookup" and "lookup_only" in SymbolTable (and StringTable well?) could be renamed to make reading the code easier:

      currently there are lookup and lookup_only, which should be refactored into lookup, lookup_and_add, lookup_only_and_hash

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gziemski Gerard Ziemski
                Reporter:
                gziemski Gerard Ziemski
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: