Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8043126

move awt automated functional tests from AWT_Events/Lw and AWT_Events/AWT to OpenJDK repository

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: client-libs
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b26

      Backports

        Description

        refactor/move the following tests to OpenJDK as a part of the colocation effort (if there are no analogs in regression suites):

        AWT_Events/Automated/Lw/ExModifiersTest
        AWT_Events/Automated/Lw/ExModifiersTextTest
        AWT_Events/Automated/Lw/FindButtonTest
        AWT_Events/Automated/Lw/KeyMaskTest
        AWT_Events/Automated/Lw/MouseButtonExTest
        AWT_Events/Automated/Lw/MouseButtonMaskTest
        AWT_Events/Automated/Lw/MouseButtonTest
        AWT_Events/Automated/Lw/MultipleMouseButtonTest

        part of them should be united with the similar tests from AWT_Events/AWT, like
        AWT_Events/Automated/AWT/ExModifiersTest
        AWT_Events/Automated/AWT/ExModifiersTextTest
        AWT_Events/Automated/AWT/FindButtonTest
        AWT_Events/Automated/AWT/KeyMaskTest
        AWT_Events/Automated/AWT/MouseButtonExTest
        AWT_Events/Automated/AWT/MouseButtonMaskTest
        AWT_Events/Automated/AWT/MouseButtonTest
        AWT_Events/Automated/AWT/MultipleMouseButtonTest


        The LW tests use library awtsqe.lw, so the part of it should be moved to OpenJDK too (as a helper classes).

          Issue Links

            Activity

            avstepan Alexander Stepanov added a comment - - edited
            some of the tests are failing due to JDK-8037369, JDK-8020120
            avstepan Alexander Stepanov added a comment -
            choice component was removed from the tests as per the following comment from JDK-8037369:

            "Functional tests will be moved to regression tests tree.
            I believe, we should throw away java.awt.Choice component from tests due to platform specific behavior."
            hgupdate HG Updates added a comment -
            URL: http://hg.openjdk.java.net/jdk9/client/jdk/rev/928621062f51
            User: yan
            Date: 2014-07-08 12:02:20 +0000
            hgupdate HG Updates added a comment -
            URL: http://hg.openjdk.java.net/jdk9/jdk9/jdk/rev/928621062f51
            User: lana
            Date: 2014-08-08 16:52:24 +0000

              People

              • Assignee:
                avstepan Alexander Stepanov
                Reporter:
                avstepan Alexander Stepanov
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: