Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8046883

com/sun/jdi/ProcessAttachTest.sh gets "java.io.IOException: Invalid process identifier" on windows

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b22
    • OS:
      windows

      Description

      -----
      \\nTest 2: Debuggee start with suspend=y
            PID PPID PGID WINPID TTY UID STIME COMMAND
          50072 66760 66760 70088 ? 400 10:50:11 /cygdrive/e/Jenkins/workspace/jdk9-dev-build-win/build/windows-x86_64-normal-server-release/images/j2sdk-image/bin/java
      Waiting for Debuggee to initialize...
      Debuggee is process WINPID (startpid=50072)
      Debugger is attaching to: WINPID ...
      Exception in thread "main" java.io.IOException: Invalid process identifier
              at com.sun.tools.jdi.ProcessAttachingConnector.attach(ProcessAttachingConnector.java:104)
              at ProcessAttachDebugger.main(ProcessAttachDebugger.java:68)
      Error: ProcessAttachDebugger failed: 0
      Waiting for port file to be written...
      Waiting 1 second(s) ...
      Waiting 2 second(s) ...
      Waiting 3 second(s) ...
      Waiting 4 second(s) ...
      Waiting 5 second(s) ...
      Waiting 6 second(s) ...
      Waiting 7 second(s) ...
      ...

        Attachments

          Activity

            People

            • Assignee:
              sla Staffan Larsen (Inactive)
              Reporter:
              sla Staffan Larsen (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: