Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8047821

G1 Does not use the save_marks functionality as intended

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
      gc
    • Resolved In Build:
      b24

      Backports

        Description

        As part of a larger effort to detach G1's HeapRegion from ContiguousSpace
        and as a general cleanup we should rename the save_marks and set_saved_marks
        methods on HeapRegion. They are not used with oops_since_saved_marks_iterate
        and cause more confusion than anything.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                mgerdin Mikael Gerdin (Inactive)
                Reporter:
                mgerdin Mikael Gerdin (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: