Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8050002

Tests failed to compile after JDK-8011044: 1.5 is no longer supported

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3
    • Resolution: Duplicate
    • Affects Version/s: 9
    • Fix Version/s: None
    • Component/s: core-libs
    • Labels:

      Description

      java/lang/Class/forName/NonJavaNames.sh
      tools/pack200/PackageVersionTest.java

      Above tests start failing after JDK-8011044:

      ----------System.err:(19/956)----------
      warning: [options] bootstrap class path not set in conjunction with -source 1.5
      error: Source option 1.5 is no longer supported. Use 1.6 or later.
      error: Target option 1.5 is no longer supported. Use 1.6 or later.
      2 errors
      1 warning
      java.lang.RuntimeException: compilation failed

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                sherman Xueming Shen
                Reporter:
                amlu Amy Lu
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: