Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8051372

Applet can't be loaded and the browser will hang,and an exception will be thrown for jre1.5 and jre1.6.

    Details

    • CPU:
      x86
    • OS:
      windows_7

      Description

      Testsuite:dynamicBaseline in core
      Test name(s):testMultiJREInsecureInstalled1
      Product(s) tested:Jre8u25b07 32bit
      OS/architecture:Windows 7 SP1 x64

      Reproducible: Always
      Reproducible on machine:egtc

      Is it a Regression:Yes

      [If Regression] Regression introduced in release/build:Jre 8u25b05 32bit+Windows 7 SP1 x64+32bit IE9
      (Jre 8u25b06 32bit+Windows 7 SP1 x64+32bit IE9:FAILED)
      (Jre 8u25b05 32bit+Windows 7 SP1 x64+32bit IE9:FAILED)
      (Jre 8u25b04 32bit+Windows 7 SP1 x64+32bit IE9:PASS)

      Test result on the last GAed release for this train:Pass
      (Jre 8u5b13 32bit+Windows 7 SP1 x64+32bit IE9)

      [if Fail] Test result on FCS:


      Is it a platform specific issue:Yes(This case only failed on windows system.
      check this case on OEL5.6 x86 and Mac 10.9 with the same build 8u25b07:PASS)


      Exception/Error from Log:
      http://scaaa008.us.oracle.com:9502/runs%2F535110.ManualSubmit-1/dynamicBaselineScenarios/testMultiJREInsecureInstalled1.jtr

      Copy JDF workspace,install test jre,and run this case
      Steps to reproduce:

      1.Uninstall all JREs from the test system
      2.Install insecure JRE versions from each JRE family:
      For x86 jre testing: 1.4.2 (eg. 1.4.2_30), 1.5 (e.g 1.5.0_33), 1.6.0 (e.g 1.6.0_30) and 1.7.0 (e.g 1.7.0_10)
      For x64 jre testing only install JREs from 1.5 (skip 1.5 testing on linux-x64) , 1.6.0 and 1.7.0 family

      Note: Insecure JRE from the same family as JRE under test should be installed once JRE under test is installed e.g if JRE version under test is 7u65 then 7u10 should be installed after installing 7u65
      3.Install the JRE under test.
      4.Clear deployment cache by running javaws -uninstall
      5.Invoke Java Control Panel > Security and click on Edit Site List. Add Entry http://localhost:8080/
      6.Remove baseline.versions from deployment_user_home/security if exists
      7.Try to load html page with multiple applets with each applet requesting different JRE families from the installed list of JREs: http://localhost:8080/dynamicBaseline/html/JREMultiFamilyTest.html
      8.Security warning dialog should be there since applets are unsigned. Check the checkbox "I accept the risk and want to run..." . Click "Run" to on the dialog
      9.Security dialog should be there asking user to run with latest version or request insecure version of JRE from each of the applet
      10.Inside each dialog select to run with latest version of JRE and Click Continue.
      11.make sure that each of the applet is getting launched with latest version of JRE

      The actual result:
      Applet can't be loaded and the browser will hang,and an exception will be thrown for jre1.5 and jre1.6.Please refer to 1.jpg

        Attachments

          Activity

            People

            • Assignee:
              almatvee Alexander Matveev
              Reporter:
              michaelw Michael Wang (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: