Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8055188

General cleanup of minor issues from source restructure


    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: infrastructure
    • Labels:
    • Subcomponent:
    • Resolved In Build:



        From Magnus' review post:

        * The new directory jdk/make/bundle should instead reside in jdk/make/data/bundles.

        * In GensrcSwing.gmk is a "$(if $(SHUFFLED)..." part that seems to be remnants of older, temporary work.

        * In CreateJars.gmk, in BUILD_TOOLS_JAR: The following looks like a duplication; I believe the "classes" version should be removed.
        $(JDK_OUTPUTDIR)/modules/jdk.jdi/META-INF/services/com.sun.jdi.connect.Connector \
        $(JDK_OUTPUTDIR)/classes/META-INF/services/com.sun.jdi.connect.Connector \

        * In CreateSecurityJars.gmk, there is a variable SECURITY_CLASSES_SUBDIR that is always set to 'modules'. I believe this is remains of an older temporary design, and that "modules" should be hard-coded into the paths.

        * The old Setup.gmk had a very generic-sounding name, even though it only did setup java compilers. So, the rename to SetupJava.gmk was good; however, I'd suggest we follow it through all the way and rename it further to SetupJavaCompilers.gmk, since that is an even more accurate description of it's job.

        * The file CopyIntoClasses.gmk is not used anymore and should be removed.

        * In CoreLibraries.gmk, there used to be a line "BUILD_LIBRARIES += $(BUILD_LIBFDLIBM)" which is now removed. After discussion with Erik, I learned that this was since the libfdlibm was not delivered in itself, but was used solely as a helper lib for libjava, which has BUILD_LIBFDLIBM as a requirement. While this change is thus correct, I believe a comment describing this fact would be in place on libfdlibm, since it makes it behave differently than all other libraries.

        * In CopyCommon, the variables LIBDIR and INCLUDEDIR has very generic-sounding name even though they are very specific. These names are not new, but since the definition is now in a different file than the uses of it, the badly chosen names makes it even harder to understand the code.

        * The platform-specific correspondance, OPENJDK_TARGET_OS_INCLUDE = $(INCLUDEDIR)/$(OPENJDK_TARGET_OS) is also bad from several perspectives: It is a variant of INCLUDEDIR but it does not end in DIR, it should not start with OPENJDK since it's not a global variable, and finally it uses incorrect assignment (= instead of :=).

        * The BUILD_LIBT2K is used only by the Oracle closed build, and the definition should move to the closed sources.


            Issue Links



                • Assignee:
                  erikj Erik Joelsson
                  erikj Erik Joelsson
                • Votes:
                  0 Vote for this issue
                  3 Start watching this issue


                  • Created: