Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8055518

Regression: Visual Styles, Tooltips and Messages not applied to SWT based JNLP

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Duplicate
    • Affects Version/s: 7u65, 7u67
    • Fix Version/s: 8u25
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b13
    • CPU:
      x86_64
    • OS:
      windows_7

      Description

      FULL PRODUCT VERSION :
      java version "1.7.0_67"
      Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
      Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

      ADDITIONAL OS VERSION INFORMATION :
      Microsoft Windows [Version 6.1.7601]

      A DESCRIPTION OF THE PROBLEM :
      Intro
      ------
      I'm filing this bug on behalf of EMC Corp, as we have a GUI application for at least one of our products that uses SWT application which is started by Java Web Start (JNLP).
      This bug is preventing the GUI from it's intended look and feel and damage it severly.

      Description
      ----------------
      Tooltips and Messages (for empty text fields) are not being shown when using java 1.7.0_65 or newer version for SWT applications started with Java Web Start.

      As it seems from Eclipse SWT bug 439759 (https://bugs.eclipse.org/bugs/show_bug.cgi?id=439759), the problem also include the entire visual style and it is related to change of using jp2launcher.exe instead of javaw.exe.

      It seems that the open JDK community has fixed this issue in the open JDK. see bug in link "https://bugs.openjdk.java.net/browse/JDK-8051891" for more information.

      Expected Response
      ----------------------------
      We are looking for estimated fix date or at least approve/disprove for the commitment to fix this bug.

      REGRESSION. Last worked in version 7u60

      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      1. update (or install) java 1.7.0_65 or 1.7.0_67
      2. run www.eclipse.org/swt/jws/controlexample.jnlp
      3. go to tootips section, set tooltips visible checkbox to true then check if the tooltip is shown (it is also possible to install java 1.7.0_60 and run the same application to see the differences more clearly).

      EXPECTED VERSUS ACTUAL BEHAVIOR :
      EXPECTED -
      Tooltips and Messages (for empty text fields) will be shown.
      ACTUAL -
      Tooltips and Messages (for empty text fields) are not shown at all.

      ERROR MESSAGES/STACK TRACES THAT OCCUR :
      no errors

      REPRODUCIBILITY :
      This bug can be reproduced always.

      CUSTOMER SUBMITTED WORKAROUND :
      add the property "deployment.security.use.insecure.launcher" to the deploy.properties on user level and set it to true.

      this workaround is not good enough as it needs to be done on each client machine.

      SUPPORT :
      YES

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                aivanov Alexey Ivanov
                Reporter:
                webbuggrp Webbug Group
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: